ETLGraph

Εργαλείο Γραφικής Αναπαράστασης ETL Σεναρίων

Εργαστήριο Συστημάτων Βάσεων Γνώσεων και Δεδομένων

Εθνικό Μετσόβιο Πολυτεχνείο

Παναγιώτης Γεωργαντάς

pgeor@dblab.ntua.gr


Οδηγίες Εγκατάστασης

  • Εκτελέσιμο αρχείο εγκατάστασης

Εκτελέστε το επιθυμητό αρχείο εγκατάστασης και ακολουθείστε τις οδηγίες ώστε να εγκατασταθεί η εφαρμογή.

Για να απεγκαταστήσετε την εφαρμογή πηγαίνετε στο “Προσθαφαίρεση Προγραμμάτων” (Add/Remove Programs) στον πίνακα ελέγχου (Control Panel) και επιλέξτε απεγκατάσταση της ARKTOSII .

  • Εγκατάσταση των αρχείων από συμπιεσμένο αρχείο.

Αποσυμπιέστε το αρχείο ARKTOSII.zip στον φάκελο της επιλογής σας.

Για να απεγκαταστήσετε την εφαρμογή διαγράψτε τον φάκελο στον οποίο έγινε η αποσυμπίεση.

  • Προαπαιτούμενα

i. Oracle Client Tools

ii. Microsoft Data Access Components (έκδοση 2.5 ή νεότερη, διαθέσιμα από τη διεύθυνση http://msdn.microsoft.com/library/default.asp?url=/downloads/list/dataaccess.asp )

Για να συνδεθείτε σε μία υπάρχουσα βάση δεδομένων Oracle Database ακολουθείστε τις παρακάτω οδηγίες:

Εκτελέστε την εφαρμογή Data Source Administrator (βρίσκεται στο Control Panelà Administrative tools).

Δημιουργείστε μία νέα πηγή δεδομένων χρήστη ή συστήματος (User ή System DSN) πατώντας το κουμπί “add” στην αντίστοιχη καρτέλα. Επιλέξτε τον κατάλληλο οδηγό για τη βάση δεδομένων σας (συνήθως Microsoft ODBC for Oracle ή Oracle in OraHomeXX όπου XX η έκδοση της Oracle που χρησιμοποιείτε). Στο πεδίο Data Source Name δώστε το όνομα που επιθυμείτε. Γράψτε το SID της Oracle στο πεδίο “Server” εάν επιλέξατε τον οδηγό της Microsoft ή στο πεδίο ”TNS Service Name” εάν επιλέξατε τον οδηγό της Oracle.

Όταν εκτελέσετε την εφαρμογή και σας ζητηθεί το repository δώστε το όνομα της πηγής δεδομένων που μόλις ορίσατε.


Εκκίνηση

Με την εκκίνηση του προγράμματος καλείστε να κάνετε Login και να ορίσετε το repository που θα χρησιμοποιηθεί.


Login

Ζητείται ένα αναγνωριστικό όνομα το οποίο θα αποτελεί την ταυτότητά του κατά τη χρήση του εργαλείου. Ο χρήστης με το συγκεκριμένο αναγνωριστικό θα μπορεί να βλέπει, να επεξεργάζεται και να διαγράφει μόνο τα σενάρια που έχει αυτός δημιουργήσει. Στο παράθυρο που εμφανίζεται φαίνεται και το DSN (Data Source Name) του Repository. Πιέζοντας το κουμπί “Change Repository” εμφανίζεται ένα νέο παράθυρο για την αλλαγή του τρέχοντος Repository. Πιέζοντας το κουμπί “Login” εισέρχεστε στο περιβάλλον του εργαλείου υπό το αναγνωριστικό όνομα που έχετε δώσει στο διπλανό πεδίο κειμένου.


Επιλογή Repository

Στο παράθυρο επιλογής Repository παρουσιάζονται σε μία αναπτυσσόμενη λίστα όλες οι πηγές δεδομένων που είναι ορισμένες στο λειτουργικό σύστημα. Στο πεδίο “UserName” δώστε το αναγνωριστικό και στο πεδίο “Password” το συνθηματικό για τη σύνδεση στο Repository. Πατώντας το κουμπί “TEST” ελέγχεται αν τα στοιχεία είναι σωστά και αν είναι δυνατή η σύνδεση στο Repository.

Αν πραγματοποιηθεί η σύνδεση ελέγχεται αν υπάρχουν στο Repository οι απαραίτητοι πίνακες. Αν δεν βρεθούν εμφανίζεται μήνυμα αν επιθυμείτε να δημιουργηθούν οι πίνακες ή όχι.

Αν επιλέξετε να μην δημιουργηθούν οι πίνακες το Repository θεωρείται μη χρησιμοποιήσιμο.

Πιέζοντας το κουμπί “OK” τίθεται τρέχον Repository αυτό που ορίζεται από τα στοιχεία που έχουν δοθεί, με την προϋπόθεση να έχει επιτευχθεί σύνδεση σε αυτό. Πατώντας “Cancel” το Repository παραμένει το ίδιο.


Κεντρικό Παράθυρο

Αφού οριστεί το Repository και ένα όνομα χρήστη εισέρχεστε στο περιβάλλον του εργαλείου και βλέπετε το ακόλουθο παράθυρο.

Πρόκειται για το κεντρικό παράθυρο του εργαλείου στο οποίο εμφανίζονται οι διαθέσιμες επιλογές. Πιο συγκεκριμένα υπάρχουν τρία μέρη στα οποία από τα οποία μπορεί να επιλεχθεί μία λειτουργία : Τα Μενού στη κορυφή του Παραθύρου, οι γραμμές εργαλείων ακριβώς από κάτω από τα μενού και τέλος το κατακόρυφο μενού στο αριστερό μέρος του παραθύρου.


Μενού

1. File

· New Scenario : Ανοίγει ένα νέο σενάριο .

· Load Scenario : Εμφανίζει το παράθυρο φόρτωσης σεναρίου .

· Delete Scenario : Εμφανίζει το παράθυρο διαγραφής σεναρίου . (Ορατό μόνο όταν δεν υπάρχουν ανοιχτά σενάρια)

· Login : Κλείνει όλα τα ενεργά σενάρια και εμφανίζει το παράθυρο Login για τη σύνδεση νέου χρήστη. (Ορατό μόνο όταν δεν υπάρχουν ανοιχτά σενάρια)

· Save Scenario : Εμφανίζει το παράθυρο αποθήκευσης σεναρίου . (Ορατό όταν το τρέχον παράθυρο είναι αυτό της βασικής σχεδίασης σεναρίου)

· Save Scenario As : Εμφανίζει το παράθυρο νέας αποθήκευσης σεναρίου . (Ορατό όταν το τρέχον παράθυρο είναι αυτό της βασικής σχεδίασης σεναρίου)

· Print : Εκτυπώνει τον γράφο που απεικονίζεται στο τρέχον παράθυρο. (Ορατό όταν υπάρχει κάποιο ανοιχτό παράθυρο)

· Close Scenario : Κλείνει το τρέχον σενάριο . (Ορατό όταν το τρέχον παράθυρο είναι αυτό της βασικής σχεδίασης σεναρίου)

· Save Changes : Αποθηκεύει τις αλλαγές που έγιναν σε κατάσταση Activity-Zoom. (Ορατό όταν το τρέχον παράθυρο είναι αυτό του Activity-Zoom)

· Close Zooming : Κλείνει το παράθυρο Zoom σε μία Activity και επιστρέφει σε αυτό του βασικού σχεδιασμού του σεναρίου. (Ορατό όταν το τρέχον παράθυρο είναι αυτό του Activity-Zoom)

2. Types

· Show Data Types : Ανοίγει το παράθυρο δημιουργίας, επεξεργασίας και διαγραφής τύπων Δεδομένων.

· Show Function Types : Ανοίγει το παράθυρο δημιουργίας, επεξεργασίας και διαγραφής τύπων Συναρτήσεων.

· Show Activity Types : Ανοίγει το παράθυρο δημιουργίας, επεξεργασίας και διαγραφής τύπων Activities.

3. Nodes

(Ορατό όταν υπάρχει κάποιο ανοιχτό παράθυρο)

· RecordSet.

· Expanded : Εμφανίζει τα attributes του RecordSet. (Ορατό όταν το τρέχον παράθυρο είναι αυτό του Activity-Zoom)

· Mark As Not Ready : Αλλάζει το χρώμα του RecordSet ώστε να υποδηλώνεται ότι οι ιδιότητές του δεν είναι σωστά ορισμένες.

· Delete : Διαγράφει το RecordSet από το γράφο. (Ορατό όταν το τρέχον παράθυρο είναι αυτό της βασικής σχεδίασης σεναρίου)

· Properties : Εμφανίζει το παράθυρο ιδιοτήτων του RecordSet.

· Activity.

· Activity Zoom : Ανοίγει το παράθυρο – Zoom σε μία Activity. (Ορατό όταν το τρέχον παράθυρο είναι αυτό της βασικής σχεδίασης σεναρίου)

· Expanded : Εμφανίζει τα attributes, τις παραμέτρους και τις συναρτήσεις της Activity. (Ορατό όταν το τρέχον παράθυρο είναι αυτό του Activity-Zoom)

· Mark As Not Ready : Αλλάζει το χρώμα της Activity ώστε να υποδηλώνεται ότι οι ιδιότητές της δεν είναι σωστά ορισμένες.

· Delete : Διαγράφει την Activity από το γράφο. (Ορατό όταν το τρέχον παράθυρο είναι αυτό της βασικής σχεδίασης σεναρίου)

· Properties : Εμφανίζει το παράθυρο ιδιοτήτων της Activity.

· Comment.

(Ορατό όταν το τρέχον παράθυρο είναι αυτό της βασικής σχεδίασης σεναρίου)

· Delete : Διαγράφει το σχόλιο από το γράφο.

· Log.

(Ορατό όταν το τρέχον παράθυρο είναι αυτό της βασικής σχεδίασης σεναρίου)

· Delete : Διαγράφει το αρχείο παρακολούθησης από το γράφο.

· Function.

(Ορατό όταν το τρέχον παράθυρο είναι αυτό του Activity-Zoom)

· Expanded : Εμφανίζει τις παραμέτρους εισόδου και εξόδου της συνάρτησης.

· Mark As Not Ready : Αλλάζει το χρώμα της συνάρτησης ώστε να υποδηλώνεται ότι οι ιδιότητές της δεν είναι σωστά ορισμένες.

· Delete : Διαγράφει τη συνάρτηση από το γράφο.

· Properties : Εμφανίζει το παράθυρο ιδιοτήτων της συνάρτησης .

· Constant .

(Ορατό όταν το τρέχον παράθυρο είναι αυτό του Activity-Zoom)

· Mark As Not Ready : Αλλάζει το χρώμα της σταθεράς ώστε να υποδηλώνεται ότι οι ιδιότητές της δεν είναι σωστά ορισμένες.

· Delete : Διαγράφει τη σταθερά από το γράφο.

· Properties : Εμφανίζει το παράθυρο ιδιοτήτων της σταθεράς .

· Attribute.

(Ορατό όταν το τρέχον παράθυρο είναι αυτό του Activity-Zoom)

· Mark As Not Ready : Αλλάζει το χρώμα του attribute ώστε να υποδηλώνεται ότι οι ιδιότητές του δεν είναι σωστά ορισμένες.

· Delete : Διαγράφει το attribute από το γράφο.

· Properties : Εμφανίζει το παράθυρο ιδιοτήτων του attribute.

· Parameter.

(Ορατό όταν το τρέχον παράθυρο είναι αυτό του Activity-Zoom)

· Mark As Not Ready : Αλλάζει το χρώμα της παραμέτρου ώστε να υποδηλώνεται ότι οι ιδιότητές του δεν είναι σωστά ορισμένες.

· Delete : Διαγράφει την παράμετρο από το γράφο.

· Properties : Εμφανίζει το παράθυρο ιδιοτήτων της παραμέτρου .

4. Edges

(Ορατό όταν υπάρχει κάποιο ανοιχτό παράθυρο)

· Set Angle.

· None : Αφήνει την ακμή ελεύθερη.

· Straight : Κάνει την ακμή ευθεία.

· Vertical Up : Η ακμή κάνει κάθετη γωνία στο ψηλότερο σημείο της

· Vertical Down : Η ακμή κάνει κάθετη γωνία στο χαμηλότερο σημείο της

· Delete : Διαγράφει την ακμή από το γράφο.

5. View

(Ορατό όταν υπάρχει κάποιο ανοιχτό παράθυρο)

· Relationships.

Τα παρακάτω τέσσερα υπομενού εμφανίζουν / κρύβουν τις ακμές του αντίστοιχου τύπου.

· Part Of

· Instance Of : Εμφανίζει / κρύβει εκτός από τις ακμές και τους απαραίτητους κόμβους τύπων δεδομένων και συναρτήσεων.

· Regulator

· Provider

· Derived Provider

· Show Only Attributes : Εμφανίζει / Κρύβει τις παραμέτρους, τις σταθερές και τις συναρτήσεις του σεναρίου.

6. Window

Περιέχει μία λίστα με τα ανοιχτά παράθυρα.(Ορατό όταν υπάρχει κάποιο ανοιχτό παράθυρο)


Γραμμές Εργαλείων

Για να μετακινήστε μία γραμμή εργαλείων κάντε κλικ στο αριστερό της άκρο και κρατώντας το αριστερό πλήκτρο του ποντικιού μετακινήστε τη σε νέα θέση. Αν μετακινήσετε τις γραμμές εργαλείων κόμβων ή ακμών χαμηλότερα από το χώρο των γραμμών εργαλείων ‘ξεκολλάνε’ και γίνονται ανεξάρτητες.. Με δεξί κλικ μπορείτε να επιλέξετε από το αναδυόμενο μενού να προσκολληθούν σε κάποια πλευρά του κεντρικού παραθύρου.

1. Βασική Γραμμή Εργαλείων

Ανοίγει ένα νέο σενάριο .

Φορτώνει ένα σενάριο από το Repository.

Αποθηκεύει ένα σενάριο στο Repository.

Τυπώνει το γράφο του τρέχοντος παράθυρου.

2. Γραμμή Εργαλείων Σχεδίασης

Επιλογή κόμβου ή ακμής.

Μετακίνηση κόμβου ή ακμής.

Αλλαγή διαστάσεων κόμβου.

Πολλαπλή επιλογή κόμβων.

3. Γραμμή Εργαλείων Κόμβων

Τα τέσσερα πρώτα εργαλεία είναι ενεργά κατά τη βασική σχεδίαση, ενώ τα υπόλοιπα κατά το Zoom σε μία Activity.

Σχεδιασμός RecordSet.

Σχεδιασμός Activity.

Σχεδιασμός Σχολίου.

Σχεδιασμός Αρχείου Παρακολούθησης.

Σχεδιασμός Συνάρτησης.

Σχεδιασμός Σταθεράς.

Σχεδιασμός Attribute.

Σχεδιασμός Παραμέτρου.

4. Γραμμή Εργαλείων Ακμών

Σχεδιασμός Provider σχέσης.

Σχεδιασμός σχέσης Περιγραφής. (ενεργό κατά τη βασική σχεδίαση)

Σχεδιασμός Regulator σχέσης. (ενεργό κατά το Zoom)

Σχεδιασμός Part-Of σχέσης. (ενεργό κατά το Zoom)


Κατακόρυφο Μενού

1. General

· Nodes : Εμφανίζει / κρύβει την γραμμή εργαλείων κόμβων .

· Edges : Εμφανίζει / κρύβει την γραμμή εργαλείων ακμών .

· Login : Κλείνει όλα τα ενεργά σενάρια και εμφανίζει το παράθυρο Login για τη σύνδεση νέου χρήστη.

· Options : Εμφανίζει το παράθυρο επιλογών .

2. Drawing

· Activity Zoom : Ανοίγει το παράθυρο – Zoom για την επιλεγμένη Activity.

· Zoom In : Μεγεθύνει το γράφο κατά το λόγο που δίνεται.

· Zoom Out : Σμικρύνει το γράφο κατά το λόγο που δίνεται.

3. Metrics

· Consistency : Ελέγχει αν οι Provider σχέσεις του παράθυρου βασικής σχεδίασης. έχουν νόημα.

· Metrics : Εμφανίζει το παράθυρο μετρήσεων .


Παράθυρο επιλογών

Για να ρυθμίσετε τις επιλογές της εφαρμογής επιλέξτε από το κατακόρυφο μενού “Options”. Εμφανίζεται το παράθυρο του επόμενου σχήματος από το οποίο μπορείτε να κάνετε τις ρυθμίσεις που θέλετε.

Οι ρυθμίσεις που κάνατε θα κρατηθούν και θα χρησιμοποιούνται κάθε φορά που χρησιμοποιείτε την εφαρμογή.


Τύποι

Τύποι (Activities, Συναρτήσεων και Δεδομένων)

Είναι δυνατόν να ορίσετε τρεις τύπους :

1. Τύπους Δεδομένων

2. Τύπους Συναρτήσεων

3. Τύπους Activities

Εάν ένας τύπος χρειάζεται κάποιον άλλον (π.χ. τύποι Activities τύπους συναρτήσεων ή τύποι συναρτήσεων τύπους δεδομένων) βεβαιωθείτε ότι οι τελευταίοι είναι ήδη ορισμένοι στο repository, αλλιώς ορίστε τους απαιτούμενους πριν τον επιθυμητό τύπο .


Τύποι Δεδομένων

Για να επεξεργαστείτε τους τύπους δεδομένων επιλέξτε από το μενού “Types” “Show Data Types”. Ανοίγει το παράθυρο που φαίνεται στο επόμενο σχήμα.

Στην αναπτυσσόμενη λίστα βλέπετε τους τύπους δεδομένων που υπάρχουν στο Repository.

Πιέζοντας το κουμπί “NEW” μπορείτε να δημιουργήσετε ένα νέο , το κουμπί “EDIT” να επεξεργαστείτε τον επιλεγμένο τύπο και το κουμπί “DELETE” να τον διαγράψετε από το Repository. Πατώντας “CANCEL” κλείνετε τη φόρμα και επιστρέφετε στο κεντρικό παράθυρο.


Δημιουργία Νέου Τύπου Δεδομένων

Επιλέγοντας “NEW” στο παράθυρο των τύπων δεδομένων εμφανίζεται το παρακάτω παράθυρο.

Στο πεδίο “Name” δίνετε το όνομα του τύπου.

Πατώντας “SAVE” αποθηκεύεται ο νέος τύπος στο Repository και επιστρέφετε στο παράθυρο τύπων δεδομένων. Επιλέγοντας τέλος “CANCEL” επιστρέφετε στο παράθυρο τύπων δεδομένων χωρίς να σωθεί νέος τύπος.


Επεξεργασία Τύπου Δεδομένων

Επιλέγοντας “EDIT” στο παράθυρο των τύπων δεδομένων εμφανίζεται το παρακάτω παράθυρο.

Στο πεδίο “Name” αλλάζετε το όνομα του τύπου.

Πατώντας “SAVE” αποθηκεύεται η αλλαγή του τύπου στο Repository. Πατώντας “ΟK”επιστρέφετε στο παράθυρο τύπων δεδομένων. Αν έχετε κάνει κάποια αλλαγή η οποία δεν έχει αποθηκευτεί εμφανίζετε ένα παράθυρο που ρωτάει αν θέλετε να την αποθηκεύσετε ή όχι. Επιλέγοντας τέλος “CANCEL” επιστρέφετε στο παράθυρο τύπων δεδομένων χωρίς να σωθούν οι αλλαγές.


Διαγραφή Τύπου Δεδομένων

Επιλέγοντας “DELETE” στο παράθυρο των τύπων δεδομένων εμφανίζεται ένα μήνυμα που σας ζητά να επιβεβαιώσετε την επιλογή σας.

Αν απαντήσετε ναι διαγράφετε ο τύπος από το Repository.


Τύποι Συναρτήσεων

Για να επεξεργαστείτε τους τύπους συναρτήσεων επιλέξτε από το μενού “Types” “Show Function Types”. Ανοίγει το παράθυρο που φαίνεται στο επόμενο σχήμα.

Στην αναπτυσσόμενη λίστα βλέπετε τους τύπους συναρτήσεων που υπάρχουν στο Repository. Στο πεδίο “Description” υπάρχει η περιγραφή του επιλεγμένου τύπου. Στη λίστα “Inputs” εμφανίζονται οι είσοδοί του και στη λίστα “Output” η έξοδός του.

Πιέζοντας το κουμπί “NEW” μπορείτε να δημιουργήσετε ένα νέο , το κουμπί “EDIT” να επεξεργαστείτε τον επιλεγμένο τύπο και το κουμπί “DELETE” να τον διαγράψετε από το Repository. Πατώντας “CANCEL” κλείνετε τη φόρμα και επιστρέφετε στο κεντρικό παράθυρο .


Δημιουργία Νέου Τύπου Συναρτήσεων

Επιλέγοντας “NEW” στο παράθυρο των τύπων συναρτήσεων εμφανίζεται το παρακάτω παράθυρο.

Στο πεδίο “Name” δίνετε το όνομα του τύπου και στο πεδίο “Description” την περιγραφή του. Πατώντας το [image] [image] κάτω από τη λίστα εισόδων ή το πεδίο εξόδου εμφανίζεται το αντίστοιχο από τα παρακάτω παράθυρα στο οποίο μπορείτε να προσθέσετε νέα είσοδο ή έξοδο.

Στην αναπτυσσόμενη λίστα των δύο παραθύρων εμφανίζονται οι τύποι Δεδομένων που υπάρχουν στο Repository.Στο πεδίο “NAME” δίνετε το όνομα της νέας εισόδου ή εξόδου.

Πατώντας το [image] [image] κάτω από τη λίστα εισόδων ή το πεδίο εξόδου αφαιρείτε την επιλεγμένη είσοδο ή έξοδο αντίστοιχα.

Πατώντας “SAVE” αποθηκεύεται ο νέος τύπος στο Repository και επιστρέφετε στο παράθυρο τύπων συναρτήσεων. Επιλέγοντας τέλος “CANCEL” επιστρέφετε στο παράθυρο τύπων συναρτήσεων χωρίς να σωθεί νέος τύπος.


Επεξεργασία Τύπου Συνάρτησης

Επεξεργασία Τύπου Συναρτήσεων

Επιλέγοντας “EDIT” στο παράθυρο των τύπων συναρτήσεων εμφανίζεται το παρακάτω παράθυρο.

Στο πεδίο “Name” αλλάζετε το όνομα του τύπου και στο πεδίο “Description” την περιγραφή του. Πατώντας το [image] [image] κάτω από τη λίστα εισόδων ή το πεδίο εξόδου εμφανίζεται το αντίστοιχο από τα παρακάτω παράθυρα στο οποίο μπορείτε να προσθέσετε νέα είσοδο ή έξοδο.

Στην αναπτυσσόμενη λίστα των δύο παραθύρων εμφανίζονται οι τύποι Δεδομένων που υπάρχουν στο Repository.Στο πεδίο “NAME” δίνετε το όνομα της νέας εισόδου ή εξόδου.

Πατώντας το [image] [image] κάτω από τη λίστα εισόδων ή το πεδίο εξόδου αφαιρείτε την επιλεγμένη είσοδο ή έξοδο αντίστοιχα.

Πατώντας “SAVE” αποθηκεύεται η αλλαγή του τύπου στο Repository. Πατώντας “ΟK”επιστρέφετε στο παράθυρο τύπων συναρτήσεων. Αν έχετε κάνει κάποια αλλαγή η οποία δεν έχει αποθηκευτεί εμφανίζετε ένα παράθυρο που ρωτάει αν θέλετε να την αποθηκεύσετε ή όχι. Επιλέγοντας τέλος “CANCEL” επιστρέφετε στο παράθυρο τύπων συναρτήσεων χωρίς να σωθούν οι αλλαγές.


Διαγραφή Τύπου Συναρτήσης

1.1.1.1 Διαγραφή Τύπου Συναρτήσεων

Επιλέγοντας “DELETE” στο παράθυρο των τύπων συναρτήσεων εμφανίζεται ένα μήνυμα που σας ζητά να επιβεβαιώσετε την επιλογή σας.

Αν απαντήσετε ναι διαγράφετε ο τύπος από το Repository.


Τύποι Activities

Για να επεξεργαστείτε τους τύπους activities επιλέξτε από το μενού “Types” “Show Activity Types”. Ανοίγει το παράθυρο που φαίνεται στο επόμενο σχήμα.

Στην αναπτυσσόμενη λίστα βλέπετε τους τύπους activities που υπάρχουν στο Repository. Στο πεδίο “Description” υπάρχει η περιγραφή του επιλεγμένου τύπου. Στη λίστα “Parameters” εμφανίζονται οι παράμετροι που χρησιμοποιεί , στη λίστα “Additional Outputs” οι έξοδοί του και στη λίστα “Used Functions” οι συναρτήσεις του.

Πιέζοντας το κουμπί “NEW” μπορείτε να δημιουργήσετε ένα νέο , το κουμπί “EDIT” να επεξεργαστείτε τον επιλεγμένο τύπο και το κουμπί “DELETE” να τον διαγράψετε από το Repository. Πατώντας “CANCEL” κλείνετε τη φόρμα και επιστρέφετε στο κεντρικό παράθυρο .


Δημιουργία Νέου Τύπου Activities

Επιλέγοντας “NEW” στο παράθυρο των τύπων activities εμφανίζεται το παρακάτω παράθυρο.

Στο πεδίο “Name” δίνετε το όνομα του τύπου και στο πεδίο “Description” την περιγραφή του. Πατώντας το [image] [image] κάτω από τη λίστα εξόδων, παραμέτρων ή συναρτήσεων εμφανίζεται το αντίστοιχο από τα παρακάτω παράθυρα στο οποίο μπορείτε να προσθέσετε νέα έξοδο, παράμετρο ή συνάρτηση.

Στην αναπτυσσόμενη λίστα των δύο πρώτων παραθύρων εμφανίζονται οι τύποι Δεδομένων ενώ στο τρίτο οι τύποι συναρτήσεων που υπάρχουν στο Repository.Στο πεδίο “NAME” δίνετε το όνομα της νέας εξόδου, παραμέτρου ή συνάρτησης.

Πατώντας το [image] [image] κάτω από τη λίστα εξόδων, παραμέτρων ή συναρτήσεων αφαιρείτε την επιλεγμένη έξοδο, παράμετρο ή συνάρτηση.

Πατώντας “SAVE” αποθηκεύεται ο νέος τύπος στο Repository και επιστρέφετε στο παράθυρο τύπων activities. Επιλέγοντας τέλος “CANCEL” επιστρέφετε στο παράθυρο τύπων activities χωρίς να σωθεί νέος τύπος.


Επεξεργασία Τύπου Activities

Επιλέγοντας “EDIT” στο παράθυρο των τύπων activities εμφανίζεται το παρακάτω παράθυρο.

Στο πεδίο “Name” αλλάζετε το όνομα του τύπου και στο πεδίο “Description” την περιγραφή του. Πατώντας το [image] [image] κάτω από τη λίστα εξόδων, παραμέτρων ή συναρτήσεων εμφανίζεται το αντίστοιχο από τα παρακάτω παράθυρα στο οποίο μπορείτε να προσθέσετε νέα έξοδο, παράμετρο ή συνάρτηση.

Στην αναπτυσσόμενη λίστα των δύο πρώτων παραθύρων εμφανίζονται οι τύποι Δεδομένων ενώ στο τρίτο οι τύποι συναρτήσεων που υπάρχουν στο Repository.Στο πεδίο “NAME” δίνετε το όνομα της νέας εξόδου, παραμέτρου ή συνάρτησης.

Πατώντας το [image] [image] κάτω από τη λίστα εξόδων, παραμέτρων ή συναρτήσεων αφαιρείτε την επιλεγμένη έξοδο, παράμετρο ή συνάρτηση.

Πατώντας “SAVE” αποθηκεύεται η αλλαγή του τύπου στο Repository. Πατώντας “ΟK”επιστρέφετε στο παράθυρο τύπων activities. Αν έχετε κάνει κάποια αλλαγή η οποία δεν έχει αποθηκευτεί εμφανίζετε ένα παράθυρο που ρωτάει αν θέλετε να την αποθηκεύσετε ή όχι. Επιλέγοντας τέλος “CANCEL” επιστρέφετε στο παράθυρο τύπων activities χωρίς να σωθούν οι αλλαγές.


Διαγραφή Τύπου Activities

Επιλέγοντας “DELETE” στο παράθυρο των τύπων activities εμφανίζεται ένα μήνυμα που σας ζητά να επιβεβαιώσετε την επιλογή σας.

Αν απαντήσετε ναι διαγράφετε ο τύπος από το Repository.


Διαχείρηση Σεναρίων

Διαχείριση Σεναρίων

Μπορείτε να πραγματοποιήσετε τις εξής λειτουργίες :

1. Άνοιγμα Νέου Σεναρίου

2. Φόρτωση Σεναρίου από το Repository

3. Κλείσιμο Σεναρίου

4. Αποθήκευση Σεναρίου

5. Αποθήκευση Σεναρίου ως Νέο Σενάριο

6. Διαγραφή Σεναρίου


Νέο Σενάριο

Ένα νέο σενάριο μπορεί να ανοίξει είτε από το μενού FileàNew Scenario είτε από το αντίστοιχο κουμπί της γραμμής εργαλείων. Όταν επιλεχθεί το άνοιγμα νέου Σεναρίου εμφανίζεται ένα παράθυρο στο οποίο ζητείται το όνομα του Σεναρίου. Δεν επιτρέπεται να δώσετε κενό όνομα. Ο μέγιστος αριθμός ταυτόχρονα ανοιχτών σεναρίων είναι δέκα.


Φόρτωση Σεναρίου

Η φόρτωση ενός σεναρίου από το Repository μπορεί να επιλεχθεί είτε από το μενού FileàLoad Scenario είτε από το αντίστοιχο κουμπί της βασικής γραμμής εργαλείων. Όταν επιλέξετε τη φόρτωση ενός σεναρίου εμφανίζεται το παρακάτω παράθυρο.

.

Στη λίστα εμφανίζονται όλα τα σενάρια που υπάρχουν στο Repository και έχουν δημιουργηθεί υπό το αναγνωριστικό όνομα που δώσετε κατά το Login. Κάνοντας δεξί κλικ σε κάποιο σενάριο εμφανίζεται ένα αναδυόμενο μενού με τις επιλογές “RENAME” και “DELETE”.Επιλέγοντας το πρώτο μπορείτε να αλλάξετε το όνομα του επιλεγμένου σεναρίου και επιλέγοντας το δεύτερο να το διαγράψετε από το Repository.

Επιλέγοντας “LOAD” ή κάνοντας διπλό κλικ στο όνομα ενός σεναρίου φορτώνεται ο αρχιτεκτονικός γράφος του σεναρίου σε ένα νέο παράθυρο βασικής σχεδίασης, ενώ πατώντας “CANCEL” κλείνει το παράθυρο φόρτωσης σεναρίου και ξαναγυρίζετε στο κεντρικό παράθυρο.


Κλείσιμο Σεναρίου.

Ένα σενάριο κλείνει αν επιλέξετε Fileà Close ή αν πατήσετε το Χ στο πάνω δεξί μέρος του παραθύρου. Σας ζητείται να επιβεβαιώστε την επιλογή σας και αν η απάντηση είναι θετική το παράθυρο σχεδίασης του σεναρίου κλείνει.


Αποθήκευση Σεναρίου

Μπορείτε να επιλέξετε να αποθηκευτεί το σενάριο στο repository από το μενού FileàSave ή από το αντίστοιχο κουμπί της γραμμής εργαλείων. Εάν είναι η πρώτη φορά που αποθηκεύετε το σενάριο θα παρουσιαστεί το παράθυρο Αποθήκευσης Σεναρίου Ως αλλιώς αποθηκεύονται οι αλλαγές στο υπάρχον στο repository σενάριο.


Αποθήκευση Σεναρίου Ως...

Μπορείτε να επιλέξετε να σώσετε ένα σενάριο δεύτερη φορά στο Repository με ένα καινούργιο όνομα από το μενού FileàSave Scenario As… .Εμφανίζεται το παρακάτω παράθυρο.

Για το παράθυρο αυτό ισχύει ότι αναφέρθηκε και για το παράθυρο φόρτωσης σεναρίου.

Στο πεδίο “Scenario Name” δίνετε το όνομα του σεναρίου που θα αποθηκευτεί, ή μπορείτε να επιλέξετε να το αποθηκεύσετε ‘πάνω’ σε ένα υπάρχον σενάριο, διαγράφοντας τα παλιά του στοιχεία.

Επιλέγοντας “SAVE AS” ή κάνοντας διπλό κλικ στο όνομα ενός σεναρίου αποθηκεύεται το σενάριο με το καινούργιο όνομα, ενώ πατώντας “CANCEL” κλείνει το παράθυρο αποθήκευσης σεναρίου και ξαναγυρίζετε στο κεντρικό παράθυρο.


Διαγραφή Σεναρίου

1.1.1 Διαγραφή Σεναρίου

Για να διαγράψετε ένα σενάριο πρέπει να μην υπάρχουν ανοιχτά παράθυρα σχεδίασης. Επιλέγοντας το μενού FileàDelete Scenario εμφανίζεται το παρακάτω παράθυρο.

Για το παράθυρο αυτό ισχύει ότι αναφέρθηκε και για το παράθυρο φόρτωσης σεναρίου.

Επιλέγοντας “DELETE” ή κάνοντας διπλό κλικ στο όνομα ενός σεναρίου εμφανίζεται ένα νέο παράθυρο όπου πρέπει να επιβεβαιώσετε την επιλογή σας και αν απαντήσετε θετικά διαγράφεται το σενάριο, ενώ πατώντας “CANCEL” κλείνει το παράθυρο αποθήκευσης σεναρίου και ξαναγυρίζετε στο κεντρικό παράθυρο.


Σχεδίαση

H σχεδίαση του σεναρίου γίνεται είτε στο παράθυρο βασικής σχεδίασης είτε στο παράθυρο Zoom.Και στα δύο παράθυρα οι λειτουργίες σχεδίασης είναι ίδιες και διαφέρουν μόνο στο τι είδους ακμές και κόμβους επιτρέπεται να σχεδιάσετε στο καθένα.

Για να σχεδιάσετε έναν κόμβο επιλέξτε τον από την γραμμή εργαλείων των κόμβων. Στη συνέχεια κάντε κλικ στο σημείο στο οποίο θέλετε να σχεδιάσετε το γράφο. Αφού σχεδιαστεί ο κόμβος θα ανοίξει αυτόματα το παράθυρο ιδιοτήτων του, εκτός από την περίπτωση των κόμβων σχολίου και αρχείο παρακολούθησης.

Αν θέλετε να επιλέξετε έναν κόμβο επιλέξτε το εργαλείο επιλογής [image] [image] από τη γραμμή εργαλείων σχεδίασης και κάντε κλικ στον κόμβο. Οι επιλεγμένοι κόμβοι φαίνονται με διαφορετικά χρώματα από τους υπόλοιπους.

Αν θέλετε να μετακινήσετε τον κόμβο επιλέξτε το εργαλείο μετακίνησης [image] [image] από τη γραμμή εργαλείων σχεδίασης, κάντε αριστερό κλικ πάνω στον κόμβο και μετακινήστε το δείκτη του ποντικιού κρατώντας το αριστερό πλήκτρο πατημένο. Ο κόμβος θα αποτεθεί στο σημείο στο οποίο θα απελευθερώσετε το αριστερό πλήκτρο του ποντικιού.

Αν θέλετε να επιλέξετε πολλούς κόμβους ταυτόχρονα επιλέξτε το εργαλείο πολλαπλής επιλογής [image] [image] από τη γραμμή εργαλείων σχεδίασης και σχεδιάστε με το ποντίκι ένα ορθογώνιο στο παράθυρο σχεδίασης.. Οι κόμβοι που περιέχονται στο ορθογώνιο θα επιλεγούν.

Το ίδιο μπορείτε να πετύχετε και αν κάνετε κλικ στους επιθυμητούς κόμβους έχοντας πατημένο του πλήκτρο Control (Ctrl) του πληκτρολογίου.

Αν θέλετε να αλλάξετε τις διαστάσεις ενός κόμβου επιλέξτε το εργαλείο αλλαγής διαστάσεων [image] [image] από τη γραμμή εργαλείων σχεδίασης, κάντε κλικ στην πλευρά του κόμβου από την οποία θέλετε να του αλλάξετε διαστάσεις και κινήστε το δείκτη του ποντικιού, κρατώντας πατημένο το αριστερό πλήκτρο του, μέχρι να πάρει ο κόμβος τις επιθυμητές διαστάσεις.

Για να διαγράψετε έναν κόμβο επιλέξτε τον και πατήστε το Delete (Del) στο πληκτρολόγιο ή επιλέξτε το κατάλληλο μενού από τα μενού στο κεντρικό παράθυρο ή από το αναδυόμενο μενού που εμφανίζεται με δεξί κλικ στον κόμβο .

Για να σχεδιάσετε μία ακμή του γράφου επιλέξτε τον επιθυμητό τύπο ακμής από τη γραμμή εργαλείων ακμών. Κάντε κλικ στον κόμβο από τον οποίο θέλετε να ξεκινά η ακμή και κρατώντας πατημένο το αριστερό πλήκτρο του ποντικιού κινήστε το δείκτη του μέχρι τον κόμβο στον οποίο θέλετε να τερματίζει η ακμή. Θα εμφανιστεί το πιο κοντινό στο δείκτη σημείο ‘πρόσδεσης’ της ακμής.

Κινήστε το ποντίκι πλησιέστερα στο επιθυμητό σημείο πρόσδεσης και απελευθερώστε το αριστερό πλήκτρο του για να σχεδιαστεί η γραμμή.

Αν απελευθερώστε το αριστερό πλήκτρο του ποντικιού σε κάποιο σημείου του παραθύρου στο οποίο δεν υπάρχει κόμβος ή σε κόμβο που δεν επιτρέπεται από τον τύπο της ακμής, η ακμή διαγράφεται.

Μία ακμή μπορεί να ‘πιαστεί’ από τρία σημεία : την αρχή, τη μέση ή το τέλος της. Κάνοντας κλικ σε ένα από τα σημεία αυτά και μετακινώντας το δείκτη του ποντικιού κρατώντας το αριστερό πλήκτρο του πατημένο, μετακινείτε το αντίστοιχο σημείο της ακμής.

Μπορείτε να κάνετε την ακμή να έχει μία συγκεκριμένη γωνία από το αναδυόμενο μενού που εμφανίζεται με δεξί κλικ πάνω σε ένα από τα τρία προαναφερθέντα σημεία ή από το μενού του κεντρικού παραθύρου.

Για να μεγαλώσετε ή να μικρύνετε την περιοχή σχεδίασης κάντε κλικ στο εικονίδιο στο κάτω δεξιό μέρος του παραθύρου σχεδίασης και κινήστε το ποντίκι προς την κατεύθυνση προς την οποία θέλετε να αλλάξουν οι διαστάσεις της περιοχής σχεδίασης .

Οι επόμενοι δύο πίνακες δείχνουν τα είδη των κόμβων και των σχέσεων που επιτρέπεται να σχεδιαστούν στα δύο παράθυρα σχεδίασης.

 | Activity | RecordSet | Σχόλιο | LOG | Attribute | Παράμετρος | Συνάρτηση | Σταθερά
Βασική Σχεδίαση | O | O | O | O | X | X | X | X
Zoom | X | X | X | X | O | O | O | O

Τύπος Ακμής | ΑΠΟ | ΣΕ | ΠΑΡΑΘΥΡΟ
 |  |  | Βασική Σχεδίαση | ΖΟΟΜ
Περιγραφής | Σχόλιο | Activity | O | X
Περιγραφής | Activity | LOG | O | X
Provider | Activity | RecordSet | O | X
 | RecordSet | Activity | O | X
 | Attribute | Attribute | X | O
Regulator | Σταθερά | Είσοδο Συνάρτησης | X | O
 | Attribute RecordSet | Είσοδο Συνάρτησης | X | O
 | Σταθερά | Παράμετρο | X | O
 | Attribute RecordSet | Παράμετρο | X | O
 | Έξοδο Συνάρτησης | Παράμετρο | X | O
 | Είσοδο Activity | Παράμετρο της ίδιας Activity | X | O
 | Παράμετρο | Έξοδο της ίδιας Activity | X | O
Part-Of | RecordSet | Attribute | X | O
 | Activity | Attribute | X | O
 | Activity | Παράμετρο | X | O
 | Activity | Συνάρτηση | X | O


Ιδιότητες

Ιδιότητες Κόμβων

Στον γράφο Αρχιτεκτονικής ενός ETL σεναρίου υπάρχουν έξι είδη κόμβων τις ιδιότητες των οποίων μπορείτε να επεξεργαστείτε:

1. Παράμετροι

2. Attributes

3. Σταθερές

4. Συναρτήσεις

5. RecordSets

6. Activities


Ιδιότητες Attribute

Οι ιδιότητες ενός attribute ρυθμίζονται από το παρακάτω παράθυρο.

Για το παράθυρο αυτό ισχύουν παρόμοια με το παράθυρο ιδιοτήτων μίας παραμέτρου.


Ιδιότητες Παραμέτρου

Οι ιδιότητες μίας παραμέτρου ρυθμίζονται από το παρακάτω παράθυρο.

Στο πεδίο “NAME” εμφανίζεται το όνομα της παραμέτρου. Στην αναπτυσσόμενη λίστα “TYPE” εμφανίζονται οι ορισμένοι στο Repository τύποι Δεδομένων, από τους οποίους μπορείτε να διαλέξετε τον τύπο της παραμέτρου.

Αν αυτή ανήκει σε κάποια Activity τότε το πεδίο αυτό είναι κλειδωμένο και δεν μπορείτε να αλλάξετε τον τύπο της παραμέτρου, όπως φαίνεται στο παρακάτω παράθυρο.

Επιλέγοντας “OK” αλλάζετε τις ιδιότητες της παραμέτρου, ενώ επιλέγοντας “CANCEL” κλείνετε το παράθυρο ιδιοτήτων της παραμέτρου χωρίς να πραγματοποιήσετε αλλαγές.


Ιδιότητες Σταθεράς

Οι ιδιότητες μίας σταθεράς ρυθμίζονται από το παρακάτω παράθυρο.

Για το παράθυρο αυτό ισχύουν παρόμοια με το παράθυρο ιδιοτήτων μίας παραμέτρου.


Ιδιότητες Συνάρτησης

Οι ιδιότητες μίας συνάρτησης ρυθμίζονται από το παρακάτω παράθυρο.

Για το παράθυρο αυτό ισχύουν παρόμοια με το παράθυρο ιδιοτήτων μίας παραμέτρου.


Ιδιότητες RecordSet

Οι ιδιότητες ενός RecordSet ρυθμίζονται από το παρακάτω παράθυρο.

Στο πεδίο Name εμφανίζεται το όνομα του RecordSet ενώ στην ακριβώς από κάτω λίστα τα attributes του. Πατώντας το κουμπί “LOAD DB” εμφανίζεται το επόμενο παράθυρο.

Στo παράθυρο αυτό μπορείτε να επιλέξετε μία από τις πηγές δεδομένων που είναι φορτωμένες στο σύστημά σας και από την οποία θέλετε να παίρνει δεδομένα το εν λόγω RecordSet.Στα πεδία “User Name” και “Password” δώστε αντίστοιχα το όνομα ενός χρήστη και το συνθηματικό του για τη σύνδεση στη βάση. Πατήστε “OK” για να φορτώσετε στο δέντρο στα αριστερά της φόρμας ιδιοτήτων τους πίνακες που ανήκουν στο χρήστη της επιλεγμένης Βάσης Δεδομένων ή “CANCEL” για να κλείσετε το παράθυρο χωρίς να φορτώσετε τους πίνακες της Βάσης. Στο επόμενο σχήμα φαίνεται το παράθυρο ιδιοτήτων ενός RecordSet με φορτωμένο στο δέντρο το σχήμα μίας Βάσης.

Κάνοντας κλικ στο τετράγωνο ελέγχου ενός κόμβου-πεδίου της βάσης ή με Drag&Drop αυτός προστίθεται ή αφαιρείται από τη λίστα των attributes, ενώ αν πρόκειται για κόμβο-πίνακα τότε προστίθενται – αφαιρούνται όλα τα πεδία του. Πατώντας το “<” μπορείτε να αφαιρέσετε το επιλεγμένο attribute από τη λίστα, ενώ πατώντας το “<<” καθαρίζετε τη λίστα από όλα τα attributes. Με τα κουμπιά που βρίσκονται στο δεξί μέρος του παραθύρου μπορείτε να αλλάξετε τη σειρά των attributes στη λίστα. Κάνοντας δεξί κλικ πάνω σε ένα attribute της λίστας μπορείτε να το αφαιρέσετε από αυτή ή να αλλάξετε το όνομά του. Τα ονόματα των attributes μεταξύ τους πρέπει να είναι μοναδικά μεταξύ τους. Πρότυπα, τα πεδία που προστίθενται παίρνουν το όνομα του πεδίου της Βάσης από το οποίο προήλθαν.

Στο κάτω μέρος του παραθύρου υπάρχει ένα μεγάλο πεδίο κειμένου. Αν είναι επιλεγμένο το τετράγωνο ελέγχου “SQL Sentence” μπορείτε να γράψετε εκεί μία πρόταση SQL που αντιστοιχεί στην επιλογή των δεδομένων από τη Βάση. Πατώντας το “Create SQL Sentence” δημιουργείται αυτόματα μία τυπική πρόταση φόρτωσης όλων των δεδομένων των πεδίων που έχουν επιλεχθεί στα αντίστοιχα attributes του RecordSet.

Στο παρακάτω σχήμα φαίνεται το παράθυρο ιδιοτήτων ενός RecordSet του οποίου έχουν τεθεί πλήρως οι ιδιότητες.


Ιδιότητες Activity

Οι ιδιότητες μίας Activity ρυθμίζονται από το παρακάτω παράθυρο.

Στο πεδίο “Activity Name” εμφανίζεται το όνομα της Activity, στο πεδίο “Activity Description” η περιγραφή της και τέλος στην αναπτυσσόμενη λίστα “Activity Type” υπάρχουν όλοι οι τύποι Activities που είναι ορισμένοι στο Repository, από τους οποίους ο επιλεγμένος είναι ο τύπος της τρέχουσας Activity. Ακριβώς από κάτω υπάρχουν τέσσερις καρτέλες. Στην πρώτη , την “Inputs”, υπάρχει μια λίστα με τα attributes εισόδου της Activity, στη δεύτερη , την “Outputs”, μια λίστα με τα attributes εξόδου της και στην τρίτη , την “Parameters”, υπάρχει μια λίστα με τις παραμέτρους της και τις συναρτήσεις που χρησιμοποιεί. Στην τέταρτη καρτέλα, τέλος, μπορείτε να ορίσετε ένα αρχείο παρακολούθησης στο οποίο θα γράφονται τα δεδομένα που δεν περνούν τον έλεγχο της Activity. Κάτω από τις καρτέλες υπάρχει ένα πεδίο κειμένου στο οποίο γράφεται η ισοδύναμη της Activity ψευδο-SQL πρόταση.

Στα δέντρα στο αριστερό τμήμα του παραθύρου εμφανίζονται τα στοιχεία του σεναρίου που μπορούν να χρησιμοποιηθούν από μία Activity. Στο δέντρο “RecordSets” εμφανίζονται τα RecordSets του σεναρίου ενώ στο δέντρο “Graph” οι Activities και οι έξοδοί τους, οι σταθερές και οι συναρτήσεις που έχουν σχεδιαστεί.

Κάνοντας κλικ στο τετράγωνο ελέγχου ενός κόμβου των δέντρων ή με Drag&Drop αυτός προστίθεται στην ή αφαιρείται από την ενεργή λίστα ή τη λίστα στην οποία επιτρέπεται να υπάρχει, ενώ αν πρόκειται για κόμβο με παιδιά τότε προστίθενται – αφαιρούνται όλα τα παιδιά του. Πατώντας το “<” μπορείτε να αφαιρέσετε το επιλεγμένο στοιχείο της ενεργής λίστας, ενώ πατώντας το “<<” καθαρίζετε την ενεργή λίστα από όλα τα στοιχεία της. Με τα κουμπιά που βρίσκονται στο δεξί μέρος του RecordSet μπορείτε να αλλάξετε τη σειρά των στοιχείων μίας λίστας.

Στον πίνακα που φαίνεται στη συνέχεια αναφέρεται σε ποιες λίστες επιτρέπεται να μπουν τα στοιχεία του σεναρίου.

 | ΛΙΣΤΑ ΕΙΣΟΔΩΝ | ΛΙΣΤΑ ΕΞΟΔΩΝ | ΛΙΣΤΑ ΠΑΡΑΜΕΤΡΩΝ
Έξοδος Activity | Ο | Χ | Χ
Attribute RecordSet | Ο | Ο | Ο
Σταθερά | Χ | Χ | Ο
Συνάρτηση | Χ | Χ | Ο

Πατήστε “Apply” για να αλλάξετε τις ιδιότητες του κόμβου, και “ΟΚ” για να κάνετε το ίδιο και να κλείσετε το παράθυρο. Επιλέγοντας “CANCEL” κλείνετε το παράθυρο χωρίς να γίνει καμία αλλαγή.


Μετρήσεις Σπουδαιότητας

Μπορείτε να δείτε τις μετρήσεις σπουδαιότητας πατώντας το αντίστοιχο κουμπί της μπάρας “Drawing” του κατακόρυφου μενού. Οι μετρήσεις παρουσιάζονται στο παρακάτω παράθυρο.

Στην αναπτυσσόμενη λίστα “Structured Entities” επιλέγετε την οντότητα του γράφου (Activity ή RecordSet) της οποίας θέλετε να δείτε τις μετρήσεις. Στο μετρητή δίπλα στη λίστα δώστε το βάθος στο οποίο θέλετε να υπολογιστούν οι μεταβατικές μετρήσεις. Πατήστε “REFRESH” αν έχετε αλλάξει κάτι και θέλετε να ανανεωθούν οι μετρήσεις. Στα απόμενα σχήματα φαίνονται οι μετρήσεις για μία Activity και ένα RecordSet αντίστοιχα. Κάνοντας κλικ στην επικεφαλίδα (IN,OUT,DEGREE) κάθε στήλης, ταξινομείτε τις λίστες με βάση τη στήλη αυτή.